SUBSIM Radio Room Forums



SUBSIM: The Web's #1 resource for all submarine & naval simulations since 1997

Go Back   SUBSIM Radio Room Forums > Silent Hunter 3 - 4 - 5 > SH5 Mods Workshop
Forget password? Reset here

Get ready for a whole new level of realism!
Reply
 
Thread Tools Display Modes
Old 12-03-22, 01:05 PM   #14131
kobiwaldi
Seaman
 
Join Date: Oct 2014
Posts: 42
Downloads: 118
Uploads: 0
Default

Quote:
Originally Posted by grimsteel View Post
So, finally after some months i got into the mood for TWoS again just to find my Ship Recognition Manual bugged and the User Charts being all just black under Windows 11
I think i found the solution after some hours of fiddling around.

Something is bugged with the recognitionmanual.dds (in data\Menu\Gui\SOAN), probably some compression issue. My theory is SH5 trys to load this file before all the images of ships and the UserChart stuff and encounters a problem, leading to all the images normally loaded afterwards to not load.

Simple solution:
Install a submod that replaces the texture for the ship recognition manual, for example Pascals Version: http://www.mediafire.com/file/im25vg...s_TDC.zip/file


Everything is working again for me
Working - Ty!
kobiwaldi is offline   Reply With Quote
Old 12-03-22, 01:26 PM   #14132
Aktungbby
Gefallen Engel U-666
 
Aktungbby's Avatar
 
Join Date: Jul 2013
Location: where I'm at presently
Posts: 24,888
Downloads: 22
Uploads: 0


Support Welcome back!

kobiwaldi! back on the surface after a 5 year 'silent run'
__________________

"Only two things are infinite; The Universe and human stupidity; And I'm not too sure about the Universe"
Aktungbby is offline   Reply With Quote
Old 12-06-22, 07:53 PM   #14133
JerseySeven
Random#
 
JerseySeven's Avatar
 
Join Date: Apr 2005
Location: TX
Posts: 73
Downloads: 142
Uploads: 0
Default

Quote:
Originally Posted by Torpedo View Post
Hi everyone!
I tried to use the "Pascal_recognition handbook_for_NewsUIs_TDC" mod but unfortunately the problem is not solved for silhouttes. UZO OK, charts OK but I don't have the silhouettes in the recognition book!
I tried using Fitzcarraldo's mods, but no positive results.
Torpedo

Sorry to hear that. I think it's working on my install. I didn't get to test it more that about 15 min.

Two things:
1. Did you remember to remove "read-only" status on all the .dds files?
2. Are the .dds files still there in the folder or did they get erased?


I'll do more checking on my end when I get the chance. Hope it gets solved for you, Herr Kaleun!
JerseySeven is offline   Reply With Quote
Old 12-07-22, 03:58 AM   #14134
Torpedo
Torpedoman
 
Torpedo's Avatar
 
Join Date: Jul 2006
Location: Treviso, Italy
Posts: 243
Downloads: 1035
Uploads: 0


Default Silhouttes...

Hi JerseySeven!
Thank you for your advice and I'll get back to you right away:

1) yes I removed the "read-only -r" attribute from all .dds files.
I think you are referring only to the files contained in the "Sea" folder. Is that it? So is only the "Archive -a" attribute to be activated? that's what I did, but unfortunately the silhouettes are not seen in handbook. I checked that the .dds files don't have particular characteristics, such as the alpha channel activated for transparency, but the files all look fine and are visible with all graphic file reading programs.

2) the .dds files are present in the Sea folder and have not been deleted.

For now I use the recognition manual as is, but I would like to have everything working!
Thanks again JerrySeven!

Torpedo

P.S. Windows11 PRO v. 22H2 and I would say that from W7 until W10 I have never had any problems in many years with SH5!

Last edited by Torpedo; 12-07-22 at 05:51 AM.
Torpedo is offline   Reply With Quote
Old 12-07-22, 07:33 PM   #14135
JerseySeven
Random#
 
JerseySeven's Avatar
 
Join Date: Apr 2005
Location: TX
Posts: 73
Downloads: 142
Uploads: 0
Default

I'm not just referring to the .dds in the Sea folder. I went to the main Silent Hunter 5 folder, selected "Search Silent Hunter 5" and put .dds in the search box. There are .dds in the TWOS parts folder, a bunch in data/menu/skins, data/LngGamedata, data/Textures (both TLowRes and TNormal). I had previously set everything to read only. So I removed it from all .dds.


In the search window, Ctrl+A to highlight all the files, right click, then select properties, then uncheck read only.


Probably shouldn't matter if you are loading Pascal's Handbook last in the JSGME list.


Of course, there may be something else going on for you... just don't know what else it might be.

Last edited by JerseySeven; 12-07-22 at 07:45 PM.
JerseySeven is offline   Reply With Quote
Old 12-07-22, 07:50 PM   #14136
Torpedo
Torpedoman
 
Torpedo's Avatar
 
Join Date: Jul 2006
Location: Treviso, Italy
Posts: 243
Downloads: 1035
Uploads: 0


Default

Ok but what is the attribute you gave to all the .dds files: A = archive? or did you not select any attribute? However all my .dds files in SH5 are set with attribute "a": only archive.

Last edited by Torpedo; 12-07-22 at 08:21 PM.
Torpedo is offline   Reply With Quote
Old 12-20-22, 08:36 PM   #14137
JerseySeven
Random#
 
JerseySeven's Avatar
 
Join Date: Apr 2005
Location: TX
Posts: 73
Downloads: 142
Uploads: 0
Default

Hi Torpedo,
Sorry, it's been a busy few weeks.


So, I search for all .dds, or hell, just click on the entire Silent Hunter 5 folder,
right click, and then select "properties" from the pop up menu. I only see 3 things under "Attributes": two check boxes (Read only; Hidden) and an Advanced button. I just make sure that the "Read only" checkbox is clear. That's all!
JerseySeven is offline   Reply With Quote
Old 12-25-22, 04:05 AM   #14138
Torpedo
Torpedoman
 
Torpedo's Avatar
 
Join Date: Jul 2006
Location: Treviso, Italy
Posts: 243
Downloads: 1035
Uploads: 0


Default

Hi JerseySeven!
I did everything you suggested but I can't see the *_sil.dds file of all ships in Recognition book. Problem that other captains also have and it seems that it depends on the W11 update to 22H2. It doesn't happen to everyone and that's the mystery!

Torpedo
Torpedo is offline   Reply With Quote
Old 01-05-23, 11:40 AM   #14139
Danny12silent
Bilge Rat
 
Join Date: Sep 2022
Posts: 1
Downloads: 24
Uploads: 0
Default Sh5

i am having a lot of trubble. i had silent hunter 5 installed on my old windows 8 worked fine. had to use key code worked fine. now that the windows 8 Sh*t the bed i installed it on my new dell inspiron 15 3000 log on to ubiconect enter keycode does not work how can i fix this.
Danny12silent is offline   Reply With Quote
Old 01-05-23, 01:09 PM   #14140
Aktungbby
Gefallen Engel U-666
 
Aktungbby's Avatar
 
Join Date: Jul 2013
Location: where I'm at presently
Posts: 24,888
Downloads: 22
Uploads: 0


Default Welcome aboard!

Danny12silent!
__________________

"Only two things are infinite; The Universe and human stupidity; And I'm not too sure about the Universe"
Aktungbby is offline   Reply With Quote
Old 01-08-23, 07:03 AM   #14141
skin-nl
KapitainLeutnant
 
skin-nl's Avatar
 
Join Date: May 2010
Location: GlanerBrucke
Posts: 384
Downloads: 227
Uploads: 0
Default

Quote:
Originally Posted by Danny12silent View Post
i am having a lot of trubble. i had silent hunter 5 installed on my old windows 8 worked fine. had to use key code worked fine. now that the windows 8 Sh*t the bed i installed it on my new dell inspiron 15 3000 log on to ubiconect enter keycode does not work how can i fix this.
Thats strange.....sh5 is in my ubisoft connect library so i never use my code anymore. Last year i had a new pc setup..no trouble to install sh5..only the game updater doesn't work anymore so i needed to download the v1.2 patch manually.(I have the dvd version)
__________________
skin-nl is offline   Reply With Quote
Old 01-08-23, 05:18 PM   #14142
Highbury
The Old Man
 
Join Date: Oct 2005
Location: 51.557, -0.102
Posts: 1,305
Downloads: 167
Uploads: 0
Default

I just reinstalled SH5 for the first time in a few years. I had forgotten just how much better TWoS makes it.

Many thanks again
Highbury is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:21 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright © 1995- 2023 Subsim®
"Subsim" is a registered trademark, all rights reserved.