SUBSIM Radio Room Forums

SUBSIM Radio Room Forums (https://www.subsim.com/radioroom/index.php)
-   SH5 Mods Workshop (https://www.subsim.com/radioroom/forumdisplay.php?f=249)
-   -   [REL]The Wolves of Steel - SH5 Megamod (https://www.subsim.com/radioroom/showthread.php?t=210703)

propbeanie 11-13-22 10:24 AM

I wonder what the folks with troubles have their SH5.exe file's Properties set to, specifically on the "Compatibility" tab, but I also wonder about their screen resolution in Windows, whether it's the newer, higher resolutions, or all resolutions?

JerseySeven 11-14-22 05:22 PM

Quote:

Originally Posted by vdr1981 (Post 2837678)
Can you try next time instead of copying entire SH5 folder, copy just TDW_dragables and dll files. Will that also temporarily fix the problem?

Doesn't fix it! I have to copy all the files since I don't know which ones are being affected.

I don't want to speak too soon, but I think I've found a way to prevent the corruption of the user charts. I've set everything in the SH5 to read only except the files ending in .TDW, .ini, and the log folder and the KSDCommander files. Overkill, I know, and I need to eventually figure out what I can safely make readable. But by setting most files to read only status, I was able to play it for five hours yesterday, and even reload saves without seeing the problem occur! I've used the ENIGMA decoder without a problem as well. I'm still avoiding opening the clock, but I may find that to be OK as well.
Now that I've jinxed it, I'll have to see how the game is later tonight :03:


EDIT: Next day and user charts still work! UZO still works. Recog. manual is stuck on initial "other" picture and won't update image to new ships when you open tankers or merchants. It's some progress! Will see if I can get the recognition book glitch fixed.


@propbeanie: It's set to compatibility for windows 7 as it was when it was working fine under Win10. (I tried changing it to Vista SP2 and others - no difference). My normal desktop is 4K, 225% scale, but as with all Ubisoft sub sims, I switch to 1920x1080 100% scale before running SH5. (You probably know that SH4 won't even load if the scale isn't 100%). If only the problem were this simple.


I'm running the 22H2 update for Win11. It's known to cause problems with games and some drivers.Unfortunately, rolling back to a previous update does not seem to be possible. Microsoft just says "check for updated games and drivers". HAH! Microsoft breaks stuff in an update and expects developers to fix their mistakes!


The fact that something is changing the game files while running suggests an antivirus/antimalware program interference. One of the first things I did was exclude the D:\Games\Ubisoft\SH5 folder from being scanned. Window Defender defaults to Malwarebytes for antiviral protection, and any independent scans by Defender are turned off. So ???

JerseySeven 11-15-22 02:44 PM

@vdr1981


Here's something interesting...
I searched 'SOAN' in the working, read-only SH5 data folder and found a SOAN folder with a picture of a blank recog manual, and 7 additional files:
SOANNames.cfg from the data\Roster folder
From the data\Menu\Gui\Layout folder there was:

SOANADDInfoImg1.dds
SOANADDInfoImg2.dds
SOANADDInfoImg3.dds
SOANADDInfoImg4.dds
SOANADDInfoImg5.dds
SOANBlank.dds


In a SH5 data folder (different hard drive) where the files were not read-only, the same search found:
SOAN folder with blank recog manual
SOANNames.cfg
SOANAddInfoImg5.dds
SOANBlank.dds


THAT's ALL!! Files SOANADDInfoImg1 through 4 were missing! For some reason, these get eventually get deleted when running the non-read-only game. No wonder the recognition manual becomes blank!


Everything in the UserCharts folder was still there, so I still don't know why in the non-read-protected game they go from viewable -> blank -> not there.


Sorry to keep posting, but maybe some of this info may help to discover how to fix the Win11 problem.

Cristi_Neagu 11-15-22 03:57 PM

Maybe you can use the instructions here (https://portal.perforce.com/s/article/3035) to set up Process Monitor to see exactly who is deleting those files.

giannistabi 11-16-22 05:01 PM

Hello m8s. Very nice and interesting forum. Keep up the good work! i have one question:
I would like to install SH5 to update to "Wolves of Steel" but i cannot find download link and instructions for SH5. Can you please help?

Thank you!

Aktungbby 11-16-22 05:10 PM

Welcome aboard!
 
giannistabi!:Kaleun_Salute:

JerseySeven 11-16-22 05:59 PM

@ Cristi_Neagu
Interesting thought. I'll give it a try.


@ giannistabi
https://www.subsim.com/radioroom/dow...o=file&id=4861


Super great mod! Enjoy.

Spikos 11-16-22 07:13 PM

Quote:

Originally Posted by JerseySeven (Post 2838066)
@vdr1981


Here's something interesting...
I searched 'SOAN' in the working, read-only SH5 data folder and found a SOAN folder with a picture of a blank recog manual, and 7 additional files:
SOANNames.cfg from the data\Roster folder
From the data\Menu\Gui\Layout folder there was:

SOANADDInfoImg1.dds
SOANADDInfoImg2.dds
SOANADDInfoImg3.dds
SOANADDInfoImg4.dds
SOANADDInfoImg5.dds
SOANBlank.dds








In a SH5 data folder (different hard drive) where the files were not read-only, the same search found:
SOAN folder with blank recog manual
SOANNames.cfg
SOANAddInfoImg5.dds
SOANBlank.dds


THAT's ALL!! Files SOANADDInfoImg1 through 4 were missing! For some reason, these get eventually get deleted when running the non-read-only game. No wonder the recognition manual becomes blank!


Everything in the UserCharts folder was still there, so I still don't know why in the non-read-protected game they go from viewable -> blank -> not there.


Sorry to keep posting, but maybe some of this info may help to discover how to fix the Win11 problem.




Just wanted to say that i have the exact same problem here. Also win11. Also blank identification book and suddenly missing charts. You are not the only one with this problem. I am also totaly frustrated because i tried so many different things for hours :confused:

giannistabi 11-18-22 05:33 PM

Quote:

Originally Posted by JerseySeven (Post 2838274)
@ Cristi_Neagu
Interesting thought. I'll give it a try.


@ giannistabi
https://www.subsim.com/radioroom/dow...o=file&id=4861


Super great mod! Enjoy.

Hello m8.
i think that this "The Wolves of Steel 2.2_SH5 Exp.Pack" requires to have SH5 installed, correct?
I havent installed it and i need i link-instructions to proceed. Is there any here?

I used to play SH4 and i love it. I havent played SH5 and i am looking forward to.

Thank you!:Kaleun_Salute:

Propnut17 11-19-22 03:24 AM

Well when I started with SH5 my first step was to purchase the Steam version. Once that I had got SH5 up and running, I was able to add in the TWoS update. Hope that this helps you also to get started.

JerseySeven 11-20-22 11:58 AM

Quote:

Originally Posted by Spikos (Post 2838281)
Just wanted to say that i have the exact same problem here. Also win11. Also blank identification book and suddenly missing charts. You are not the only one with this problem. I am also totaly frustrated because i tried so many different things for hours :confused:

It's got to be something that all of us Win11 users have in common. I'm most suspicious of Windows Defender. Since the v22H2 Win11 update, it even flags Intel drivers as problematic. I've turned off "Reputation-based protection" but need more information on "Exploit protection" settings.

Meanwhile, try this it may help:
1. Make a fresh install of SH5 and TWOS and, as insurance if you need to re-copy any files, backup the newly installed folder somewhere before running the game!

2, Run JSGME and add any mods you plan to use. Then set everything in the TWOS-parts folder (except TWOS-parts/jsgme.ini) to read-only.

3. Set everything in the data folder to read-only, except data/automation and data/cfg folders.

I've been running this way for a week, without losing any user charts or getting UZO corruption. Only problem is that the image in the recognition manual is frozen and doesn't change. I haven't yet discovered what file or files I can safely change without losing the charts again.


Please reply if it works for you!

Torpedo 11-21-22 05:37 AM

UZO and User Charts OK
 
Thanks JerseySeven!
I did what you suggested and finally the UZO has no more problems and the user charts are all OK!
Unfortunately the recognition manual is frozen, but you have found solutions that make SH5 still enjoyable!
Thank you!!!

Torpedo :Kaleun_Salute::Kaleun_Applaud::Kaleun_Cheers:

propbeanie 11-21-22 10:32 AM

vdr1981 or someone more knowledgeable than me would have to confirm, but the rec manual is "built" from the Data \Menu (and Menu \Pages) folders and files, and pulls the sil files associated with the Sea folder assets. I cannot fathom why those being set to Read-only would matter though... ?? Problem with setting the Menu folder to writeable of course, is that the GUI and folders below it are set to the same attribute, exposing the SOAN files Spikos mentions... perhaps just try the Sea folder initially, and then try the Pages folder, and perhaps then the RecManual image would change??...

Alex_U-9 11-21-22 10:37 AM

Thank you very much for your work vdr1981

JerseySeven 11-21-22 05:39 PM

@Torpedo
I'm super excited that it is also helpful for you!

@propbeanie
I was hoping for the kind of insight that you've shared. I'll try making the sea folder readable initially, then if needed, the pages folder.


Tried removing 'read-only' from sea, then both sea and pages. Recog manual still frozen on the initial "other" picture. Information can be accessed, and for those ships that have 'Additional Information' the text can be read, but any associated pictures are all white.


I appreciate the suggestions though.


All times are GMT -5. The time now is 09:35 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 1995- 2023 Subsim®
"Subsim" is a registered trademark, all rights reserved.