SUBSIM Radio Room Forums

SUBSIM Radio Room Forums (https://www.subsim.com/radioroom/index.php)
-   SH5 Mods Workshop (https://www.subsim.com/radioroom/forumdisplay.php?f=249)
-   -   [REL]The Wolves of Steel - SH5 Megamod (https://www.subsim.com/radioroom/showthread.php?t=210703)

JerseySeven 11-12-22 11:13 PM

@Vecko
Thank you for your kind offer. I'm a bit frustrated at this point and am ready to give up.
If you want to have a look, I'll be glad to send you the dll files in a zipped folder.
Did you want all of the .dll files or just the ones that start with TDW?

vdr1981 11-13-22 03:19 AM

Quote:

Originally Posted by fitzcarraldo (Post 2837586)
Hi Vecko.

I use TWoS with W11 and I do not have any issue.

Not a problem with W11 for me.

Best regards.

Fitzcarraldo :Kaleun_Salute:

That's interesting but also confusing...:hmmm: Nvidia or AMD graphics?

vdr1981 11-13-22 03:27 AM

Quote:

Originally Posted by JerseySeven (Post 2837645)
If I delete the Silent Hunter 5 folder and copied all SH5-TWOS files from an unplayed backup it works fine... for awhile. In the image below, you see the user charts, and recog manual are fine, and the UZO looks normal.

https://imgur.com/a/4uZvSHD


So, Win11 can display things properly, but only for a time. Pressing 'O' for the clock messes everything again, instantly. Also, using the enigma decoder seems to also initiate the problem. Sometimes, not doing either of those actions, and the UZO and recog manual will still blank out.



BTW: I had excluded the Silent Hunter 5 folder from my antivirus sniffing around. Apparently, that was not enough to prevent recurrence of the problem.


Unless someone has a breakthrough solution, I will just install Windows 10 on a bootable USB stick, along with UPlay, and Silent Hunter 5. I'm done wasting time getting this to work in Win11.



Thankfully, I do not need to do this with SH3 or SH4.



Quote:

Originally Posted by JerseySeven (Post 2837663)
@Vecko
Thank you for your kind offer. I'm a bit frustrated at this point and am ready to give up.
If you want to have a look, I'll be glad to send you the dll files in a zipped folder.
Did you want all of the .dll files or just the ones that start with TDW?

No, I was talking about simple dds files (textures) but it seems that the problem is much more deeper than that, system related. I'm not even sure where to start to look for the issues. :hmmm: The big question now is to narrow down why some win11 users have this problem while others don't...:hmmm:

Can you try next time instead of copying entire SH5 folder, copy just TDW_dragables and dll files. Will that also temporarily fix the problem?

Cristi_Neagu 11-13-22 08:48 AM

I'm wondering if something they did to make DirectStorage happen messed something up with the older APIs...

fitzcarraldo 11-13-22 09:57 AM

Quote:

Originally Posted by vdr1981 (Post 2837677)
That's interesting but also confusing...:hmmm: Nvidia or AMD graphics?

Nvidia GC.

SH5 1.2 DVD Gold.

My list:

Generic Mod Enabler - v2.6.0.157
[E:\Ubisoft\Silent Hunter 5\TWoS_Parts]

TWoS Campaign Start_VIIB_UFlaK
TWoS FX_Incr. Flooding via Zones
TWoS Harbors Chimney Smoke
TWoS Missing Nav Map Coordinates_Fix
TWoS Remove Sub Flags
TWoS Wooden Lifeboats
Air Force for TWoS 2224_re-saved
Das Boot Departure Theme
Das Boot Gramophone music by Navuhodonosor
DBLS for TWoS
gap - The SH5 EcoMod v0.2.1 - 1. Main mod
gap - The SH5 EcoMod v0.2.1 - 2.b 3x increased tree density
gap - The SH5 EcoMod v0.2.1 - 3. Season fine-tunings (only DynEnv and TWoS users)
gap - The SH5 EcoMod v0.2.1 - 4.a Full resolution tree textures
gap - The SH5 EcoMod v0.2.1 - 5.a Full resolution detail masks
gap - The SH5 EcoMod v0.2.1 - Testing missions
DynEnv v2.9 - 10.I Seafloor (high resolution)
DynEnv v2.9 - 11.a.I Sea Plants - Atlantic Kelp Forests (high resolution)
GSE v1.2.6 by GrenSo
GSE - G7e Torpedotexture
GSE - alternative Periscope and OBS
Cameras without flicks
Pascal_recognition handbook_for_NewsUIs_TDC
Kriegsmarine Medals by U-190
Pascal-sh5-Crew-Uniforms_version14
RUSTED GLORY SH5 (LIGHTS ONLY)
SD_MapLocationNameFix_v1.2
Bstanko's Night Filter
_1_Stormys DBSM_TWos SH5 v1.3 Basemod
_2_Stormys DBSM_TWos SH5 v1.3 HOTFIX 3
_o_Stormys DBSM_TWos SH5 v1.3 additional crew sounds beta6
_o_Stormys DBSM_TWos SH5 v1.3 optional -6db damped Sonarguy
_o_Stormys DBSM_TWos SH5 v1.3 optional NavMap babelling
_o_Stormys DBSM_TWos SH5 v1.3 optional remaining orig sounds converted to 22Khz
BritishAsdicMkIFinal
Bstanko6's AlarmClock
Compans_Sub chatter
DasBootSehrohr
DeckKannon
GSE - Radione R3
NewUIs_TDC_7_5_0_Das_Boot_Crew_Mod_by_Illyustrator
No Rusted Mines and Subnets by U-190
SeawolvesVoices
Pascal_sh5_Radio_Paris
DynEnv v2.9 - Wave Mechanics - Gale (Improved)
DynEnv v2.9 - 4.b Camera Filters - Vivid Colors
DynEnv v2.9 - 6. Sleet for Winter Campaigns
DynEnv v2.9 - 3.b Enhanced Visibility (high)
SKIN_VIIC_ArcticCamo_byTheBeast
DBSM_Music_1_0_4
TWoS Real Navigation

Working well in W11.

Regards.

Fitzcarraldo :Kaleun_Salute:

propbeanie 11-13-22 10:24 AM

I wonder what the folks with troubles have their SH5.exe file's Properties set to, specifically on the "Compatibility" tab, but I also wonder about their screen resolution in Windows, whether it's the newer, higher resolutions, or all resolutions?

JerseySeven 11-14-22 05:22 PM

Quote:

Originally Posted by vdr1981 (Post 2837678)
Can you try next time instead of copying entire SH5 folder, copy just TDW_dragables and dll files. Will that also temporarily fix the problem?

Doesn't fix it! I have to copy all the files since I don't know which ones are being affected.

I don't want to speak too soon, but I think I've found a way to prevent the corruption of the user charts. I've set everything in the SH5 to read only except the files ending in .TDW, .ini, and the log folder and the KSDCommander files. Overkill, I know, and I need to eventually figure out what I can safely make readable. But by setting most files to read only status, I was able to play it for five hours yesterday, and even reload saves without seeing the problem occur! I've used the ENIGMA decoder without a problem as well. I'm still avoiding opening the clock, but I may find that to be OK as well.
Now that I've jinxed it, I'll have to see how the game is later tonight :03:


EDIT: Next day and user charts still work! UZO still works. Recog. manual is stuck on initial "other" picture and won't update image to new ships when you open tankers or merchants. It's some progress! Will see if I can get the recognition book glitch fixed.


@propbeanie: It's set to compatibility for windows 7 as it was when it was working fine under Win10. (I tried changing it to Vista SP2 and others - no difference). My normal desktop is 4K, 225% scale, but as with all Ubisoft sub sims, I switch to 1920x1080 100% scale before running SH5. (You probably know that SH4 won't even load if the scale isn't 100%). If only the problem were this simple.


I'm running the 22H2 update for Win11. It's known to cause problems with games and some drivers.Unfortunately, rolling back to a previous update does not seem to be possible. Microsoft just says "check for updated games and drivers". HAH! Microsoft breaks stuff in an update and expects developers to fix their mistakes!


The fact that something is changing the game files while running suggests an antivirus/antimalware program interference. One of the first things I did was exclude the D:\Games\Ubisoft\SH5 folder from being scanned. Window Defender defaults to Malwarebytes for antiviral protection, and any independent scans by Defender are turned off. So ???

JerseySeven 11-15-22 02:44 PM

@vdr1981


Here's something interesting...
I searched 'SOAN' in the working, read-only SH5 data folder and found a SOAN folder with a picture of a blank recog manual, and 7 additional files:
SOANNames.cfg from the data\Roster folder
From the data\Menu\Gui\Layout folder there was:

SOANADDInfoImg1.dds
SOANADDInfoImg2.dds
SOANADDInfoImg3.dds
SOANADDInfoImg4.dds
SOANADDInfoImg5.dds
SOANBlank.dds


In a SH5 data folder (different hard drive) where the files were not read-only, the same search found:
SOAN folder with blank recog manual
SOANNames.cfg
SOANAddInfoImg5.dds
SOANBlank.dds


THAT's ALL!! Files SOANADDInfoImg1 through 4 were missing! For some reason, these get eventually get deleted when running the non-read-only game. No wonder the recognition manual becomes blank!


Everything in the UserCharts folder was still there, so I still don't know why in the non-read-protected game they go from viewable -> blank -> not there.


Sorry to keep posting, but maybe some of this info may help to discover how to fix the Win11 problem.

Cristi_Neagu 11-15-22 03:57 PM

Maybe you can use the instructions here (https://portal.perforce.com/s/article/3035) to set up Process Monitor to see exactly who is deleting those files.

giannistabi 11-16-22 05:01 PM

Hello m8s. Very nice and interesting forum. Keep up the good work! i have one question:
I would like to install SH5 to update to "Wolves of Steel" but i cannot find download link and instructions for SH5. Can you please help?

Thank you!

Aktungbby 11-16-22 05:10 PM

Welcome aboard!
 
giannistabi!:Kaleun_Salute:

JerseySeven 11-16-22 05:59 PM

@ Cristi_Neagu
Interesting thought. I'll give it a try.


@ giannistabi
https://www.subsim.com/radioroom/dow...o=file&id=4861


Super great mod! Enjoy.

Spikos 11-16-22 07:13 PM

Quote:

Originally Posted by JerseySeven (Post 2838066)
@vdr1981


Here's something interesting...
I searched 'SOAN' in the working, read-only SH5 data folder and found a SOAN folder with a picture of a blank recog manual, and 7 additional files:
SOANNames.cfg from the data\Roster folder
From the data\Menu\Gui\Layout folder there was:

SOANADDInfoImg1.dds
SOANADDInfoImg2.dds
SOANADDInfoImg3.dds
SOANADDInfoImg4.dds
SOANADDInfoImg5.dds
SOANBlank.dds








In a SH5 data folder (different hard drive) where the files were not read-only, the same search found:
SOAN folder with blank recog manual
SOANNames.cfg
SOANAddInfoImg5.dds
SOANBlank.dds


THAT's ALL!! Files SOANADDInfoImg1 through 4 were missing! For some reason, these get eventually get deleted when running the non-read-only game. No wonder the recognition manual becomes blank!


Everything in the UserCharts folder was still there, so I still don't know why in the non-read-protected game they go from viewable -> blank -> not there.


Sorry to keep posting, but maybe some of this info may help to discover how to fix the Win11 problem.




Just wanted to say that i have the exact same problem here. Also win11. Also blank identification book and suddenly missing charts. You are not the only one with this problem. I am also totaly frustrated because i tried so many different things for hours :confused:

giannistabi 11-18-22 05:33 PM

Quote:

Originally Posted by JerseySeven (Post 2838274)
@ Cristi_Neagu
Interesting thought. I'll give it a try.


@ giannistabi
https://www.subsim.com/radioroom/dow...o=file&id=4861


Super great mod! Enjoy.

Hello m8.
i think that this "The Wolves of Steel 2.2_SH5 Exp.Pack" requires to have SH5 installed, correct?
I havent installed it and i need i link-instructions to proceed. Is there any here?

I used to play SH4 and i love it. I havent played SH5 and i am looking forward to.

Thank you!:Kaleun_Salute:

Propnut17 11-19-22 03:24 AM

Well when I started with SH5 my first step was to purchase the Steam version. Once that I had got SH5 up and running, I was able to add in the TWoS update. Hope that this helps you also to get started.

JerseySeven 11-20-22 11:58 AM

Quote:

Originally Posted by Spikos (Post 2838281)
Just wanted to say that i have the exact same problem here. Also win11. Also blank identification book and suddenly missing charts. You are not the only one with this problem. I am also totaly frustrated because i tried so many different things for hours :confused:

It's got to be something that all of us Win11 users have in common. I'm most suspicious of Windows Defender. Since the v22H2 Win11 update, it even flags Intel drivers as problematic. I've turned off "Reputation-based protection" but need more information on "Exploit protection" settings.

Meanwhile, try this it may help:
1. Make a fresh install of SH5 and TWOS and, as insurance if you need to re-copy any files, backup the newly installed folder somewhere before running the game!

2, Run JSGME and add any mods you plan to use. Then set everything in the TWOS-parts folder (except TWOS-parts/jsgme.ini) to read-only.

3. Set everything in the data folder to read-only, except data/automation and data/cfg folders.

I've been running this way for a week, without losing any user charts or getting UZO corruption. Only problem is that the image in the recognition manual is frozen and doesn't change. I haven't yet discovered what file or files I can safely change without losing the charts again.


Please reply if it works for you!

Torpedo 11-21-22 05:37 AM

UZO and User Charts OK
 
Thanks JerseySeven!
I did what you suggested and finally the UZO has no more problems and the user charts are all OK!
Unfortunately the recognition manual is frozen, but you have found solutions that make SH5 still enjoyable!
Thank you!!!

Torpedo :Kaleun_Salute::Kaleun_Applaud::Kaleun_Cheers:

propbeanie 11-21-22 10:32 AM

vdr1981 or someone more knowledgeable than me would have to confirm, but the rec manual is "built" from the Data \Menu (and Menu \Pages) folders and files, and pulls the sil files associated with the Sea folder assets. I cannot fathom why those being set to Read-only would matter though... ?? Problem with setting the Menu folder to writeable of course, is that the GUI and folders below it are set to the same attribute, exposing the SOAN files Spikos mentions... perhaps just try the Sea folder initially, and then try the Pages folder, and perhaps then the RecManual image would change??...

Alex_U-9 11-21-22 10:37 AM

Thank you very much for your work vdr1981

JerseySeven 11-21-22 05:39 PM

@Torpedo
I'm super excited that it is also helpful for you!

@propbeanie
I was hoping for the kind of insight that you've shared. I'll try making the sea folder readable initially, then if needed, the pages folder.


Tried removing 'read-only' from sea, then both sea and pages. Recog manual still frozen on the initial "other" picture. Information can be accessed, and for those ships that have 'Additional Information' the text can be read, but any associated pictures are all white.


I appreciate the suggestions though.


All times are GMT -5. The time now is 06:28 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 1995- 2023 Subsim®
"Subsim" is a registered trademark, all rights reserved.